Shoutbox

support:
2021 Jun 05 21:36:07
w jakimś bliżej nie określonym czasie nastąpi mała zmiana na forum, ale to jak znajdę wolny weekend czy coś podobnego
support:
2020 Nov 12 13:57:35
o taki portal na jakiś czas do nas wpadnie

na warstwach wyświetla się ${u.ETYKIETA} lub podobny kod zamiast konkretnej wartości

  • 14 Odpowiedzi
  • 5446 Wyświetleń

0 użytkowników i 1 Gość przegląda ten wątek.

Offline kuczmen

  • *
  • Bywalec
  • *
  • Wiadomości: 12
  • Płeć: Mężczyzna
  • System:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Przeglądarka:
  • Firefox 39.0 Firefox 39.0
    • Zobacz profil
Witam,
problem jak w temacie. Dotyczy warstw importowanych z ośrodka - efekt jest zarówno po imporcie warstw.txt, jak i obiektów (importowanych po odzipowaniu pliku typu "obiekty.bdot" z ośrodka
rozumiem, że te wartości są pobierane z jakiegoś pliku.
pytanie czy ten plik powinien być dostarczony z ośrodka,
 jeżeli to nie plik, a kwestia ustawień to jakie powinny one być?

z pozdrowieniami i nadzieją na odpowiedź.




Offline Nyzczsel

  • *
  • *
  • Wiadomości: 945
  • Płeć: Mężczyzna
  • System:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Przeglądarka:
  • Chrome 43.0.2357.132 Chrome 43.0.2357.132
    • Zobacz profil
A którą EwKę masz ?
Jak pisał Lupus za mało danych.
Jeszcze jedno pytanie: importujesz dane do bazy FB ?

edit:
Obiekty posiadają dane opisowe.
To przykład BUBZ:

Cytuj
Id,"Identyfikator obiektu",1,24,1
zrodlo,"Źródło",4,1,0,"BDZ_Zrodlo - Słownik wspólny"
istnienie,"Istnienie",4,1,0
informacja,"Informacja dodatkowa",1,255,0,""
dataPomiaru,"Data pomiaru",4,0,1
rodzajMatBudZiemn,"Rodzaj materiału budowli ziemnej",4,1,0
**
[BDZ_Zrodlo],""
[BDZ_Zrodlo],1,"Pomiar na osnowę","O"
[BDZ_Zrodlo],2,"Digitalizacja i wektoryzacja","D"
[BDZ_Zrodlo],3,"Fotogrametria","F"
[BDZ_Zrodlo],4,"GPS bez powiązania z osnową","G"
[BDZ_Zrodlo],5,"Inne","I"
[BDZ_Zrodlo],6,"Pomiar w oparciu o elementy mapy","M"
[BDZ_Zrodlo],7,"Nieokreślone","N"
[BDZ_Zrodlo],8,"Nieznane","X"
istnienie,1,"Istniejący","i"
istnienie,2,"Projektowany","p"
rodzajMatBudZiemn,1,"Grunt naturalny","gr"
rodzajMatBudZiemn,2,"Okładzina betonowa","bt"
rodzajMatBudZiemn,3,"Inna","i"
****
"mWIFE4GnnU634rsP5sBGiw",2,1,"",-,1
"uWRTuEMP_0CpG7eySw-goQ",2,1,"",-,1
"PAVo7aoZ40Gc5lo43_JTQA",2,1,"",-,1
"zX2xaQRLNEOSMPfjEk8Ecg",2,1,"",-,1
"fHayqLmhd0yyTfYI25djcA",2,1,"",-,1
"uO09pPmtd0qurhi5fmQ7YA",2,1,"",-,1
"VjmozRDEskKMYvJ4ByLzTQ",2,1,"",-,1
"7SOgCMi3EkKSPo1ALbfu7Q",2,1,"",-,1
"b7XJ0on5D0GOQ0lKFq4O0g",2,1,"",-,1
"vPx8sVXa7kWX5D-_Z6EYug",1,1,"",-,1
"dYt4EPZjvEOqxAkLbRJVQA",1,1,"",2015-02-17,1

« Ostatnia zmiana: 17 Lipiec 2015, 13:34 wysłana przez Nyzczsel »

Offline Pan Sowa

  • *
  • Stażysta
  • *
  • Wiadomości: 124
    • Ewmapa 13
  • System:
  • Windows XP Windows XP
  • Przeglądarka:
  • Chrome 43.0.2357.134 Chrome 43.0.2357.134
    • Zobacz profil
Importujesz do baz BDOT?
« Ostatnia zmiana: 17 Lipiec 2015, 13:50 wysłana przez Weles »
Huuu huu

Offline kuczmen

  • *
  • Bywalec
  • *
  • Wiadomości: 12
  • Płeć: Mężczyzna
  • System:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Przeglądarka:
  • Firefox 39.0 Firefox 39.0
    • Zobacz profil
EWmapa jak w opisie 11fb

bazy BDOT, GESUT założone i podłączone, lista warstw się wyświetla jak trzeba. tu nie ma problemu.
importuję przez: obiekty->import z formatu tekstowego - wybierając plik "obiekty" z odzipowanego katalogu. wyskakuje okno  z operatami, a że nie mam bazy operatów zaznaczam "zmiany bezpośrednie"

widzę te pliki z opisami obiektów - przy czym: czy i jak je podpiąć oraz do czego, jeżeli już.

dla sprawdzenia robiłem też import z tekstówek na warstwy - treść powinna być ta sama i jest tak w istocie, ale również w miejscu zmiennych na mapie wyświetla się kod .

tu jest zapewne sprawa z podłączeniem poszczególnych obiektów do listy tych etykiet cz też zmiennych.
z obiektami nie miałem do czynienia - może to być jakaś oczywistość



sYsTEM połączył wiadomości: 17 Lipiec 2015, 15:10
zgodnie z przypuszczeniem:
musi być jakiś "plik z definicją etykiet", po zaznaczeniu obiektu na mapie i kliknięciu w przycisk info
w zakładce etykiety pojawia się komunikat o braku właśnie tego pliku.

czy to jest jeden z tych plików który cytował Nyzczsel?
jeżeli tak, jak i gdzie go podłączyć?

 
« Ostatnia zmiana: 17 Lipiec 2015, 15:10 wysłana przez kuczmen »

Offline alcapon

  • *
  • *
  • Wiadomości: 1979
  • Płeć: Mężczyzna
  • System:
  • Windows Vista/Server 2008 Windows Vista/Server 2008
  • Przeglądarka:
  • Opera 30.0.1835.125 Opera 30.0.1835.125
    • Zobacz profil
Primo.... powiat który prowadzi bazę w takiej formie jak dałeś pliki to jakieś szuszfole.
Część danych bdoot mają zobiektowaną a część nie ....w dodatku dane się powtarzają  :crazy2:

Plik txt importujesz jako warstwy-import
Plik z obiektami jako obiekty import
i wsio gra i buczy.

Korepetycje z ewmapy -> ewmapa@o2.pl
http://www.youtube.com/user/ewmapa/videos

Offline kuczmen

  • *
  • Bywalec
  • *
  • Wiadomości: 12
  • Płeć: Mężczyzna
  • System:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Przeglądarka:
  • Firefox 39.0 Firefox 39.0
    • Zobacz profil
otóż nie gra  :(

jak pisałem - przy imporcie z warstw - buczy pozornie, bo nie wyświetla zmiennych (wysokość pikiety, przewodu itp) tylko kod w ${.....} w nawiasach rodzaj zmiennej.

natomiast przy imporcie z pliku obiekty.btod - jeżeli bezpośrednio - wywala błąd - "błędny format linii "pk różne znaczki" " zgodnie z zawartością.
jeżeli rozpakuję i zaimportuję tylko plik obiekty - wówczas sytuacja jak w przypadku importu z warstw.txt
pozostałe pliki (te z konfiguracją obiektów) się nie importują.

to, że ośrodek, z litości nie wymienię powiatu, prowadzą sprawni inaczej  - wiem nie od wczoraj i nie od przedwczoraj  ;)

może od tej strony:
czy import obiektów powinien przejść bez problemu bezpośrednio z pliku obiekty.bdot bez rozpakowywania?

Offline alcapon

  • *
  • *
  • Wiadomości: 1979
  • Płeć: Mężczyzna
  • System:
  • Android Android
  • Przeglądarka:
  • Opera 12.16 Opera 12.16
    • Zobacz profil
mozesz importowac bezposrednio z pliku bdot bez rozpakowywania...ale importuj jako do modyfikacji bo w takiej formie dostales plik z powiatu. jak rozpakujesz to mozesz importowac jako podstawowy.


chyba znasz roznice miedzy podstawowy a do modyfikacji.

ps. zadnego pliku z etykietami nie trzeba dodawac. napisz krok po kroku dokladnie jak zaklasales  baze bdot bo chyba tu lezy hotdog pogrzebany
Korepetycje z ewmapy -> ewmapa@o2.pl
http://www.youtube.com/user/ewmapa/videos

Offline Pan Sowa

  • *
  • Stażysta
  • *
  • Wiadomości: 124
    • Ewmapa 13
  • System:
  • Windows Vista/Server 2008 Windows Vista/Server 2008
  • Przeglądarka:
  • Chrome 43.0.2357.134 Chrome 43.0.2357.134
    • Zobacz profil
Tak, powinien. Nie powinno takze byc żadnego problemu z plikami z definicja etykiet. Te sa w bazach bdot gesut skonfigurowane. Możesz sprawdzić czy aby napewno obiekty-konfiguracja obiektów-wybierasz baze- ustawiasz sie na kodzie-i klikasz ostatnia opcje konfiguracja zmiennych. Jeśli coś tam jest to etykiety sa skonfigurowane zgodnie z propozycją GEOBID-u. U mnie po zaimportowaniu wszystko gra, importowałem tylko obiekty, nie importowałem warstw, żeby przypadkiem nie wyrzucily mi etykiet z obiektów(choć chyba nie powinny).
Huuu huu

Offline kuczmen

  • *
  • Bywalec
  • *
  • Wiadomości: 12
  • Płeć: Mężczyzna
  • System:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Przeglądarka:
  • Firefox 39.0 Firefox 39.0
    • Zobacz profil
jak zakładałem bazę BDOT: (zaznaczam, że FB działa lokalnie)

zakładam folder roboczy tak jak zwykle dla plików bazy ewmapa (tam gdzie tworzą się foldery działki,kontury itp)
zakładam podfolder gdzie umieszczam pustą bazę BDOT500 - gotowiec z ewmapy
w ewmapie konfiguracja baz, zakładam bazę, w pozycji warstwy zakładam element BDOT500, przyciskiem "zmień bazę FB" pokazuję ścieżkę do pustej bazy, lączę. wybieram z okienka katalog z warstwami podpowiadany bdot500.

oczywiście przy łączeniu za każdym razem razem jest okno logowania.

nastepnie otwórz bazę.
do tej pory wszystko  śmiga

warstwy się importują, - z plików txt
obiekty się importują  - ale tylko po rozpakowaniu pliku obiekty.bdot - bez rozpakowania dostaję komunikat błędny format linii - tu cytat z początku pliku - dziwne znaczki. Zatem rozpakowuję. imortuję z plik "obiekty" zaznaczam operaty i dane dodatkowe.

to samo dla GESUT

niby wszystko działa...
ALE
na mapie wyświetla mi te nieszczęsne kody {}  zamiast wartości. Dodatkowo po imporcie obiektów jest mniej treści niż po imporcie na warstwy. To pewnie o tym mówił Alcapon...
 

mozesz importowac bezposrednio z pliku bdot bez rozpakowywania...ale importuj jako do modyfikacji bo w takiej formie dostales plik z powiatu. jak rozpakujesz to mozesz importowac jako podstawowy.

i tu mam zonk! ponieważ mówimy o imporcie obiektów - a podstawowy czy do modyfikacji dotyczy importu warstw?
oczywiście próbowałem importować ten plik przez warstwy rozpaczliwcem, ale sami wiecie, rozumiecie ....    :o

 
« Ostatnia zmiana: 18 Lipiec 2015, 12:37 wysłana przez kuczmen »

Offline alcapon

  • *
  • *
  • Wiadomości: 1979
  • Płeć: Mężczyzna
  • System:
  • Android Android
  • Przeglądarka:
  • Opera 12.16 Opera 12.16
    • Zobacz profil
podstawowy czy do modyf dotyczy takze obiektow

ps. a kolega czasem w opcjach programu nie zaznaczył aby wyświetlać kody zmiennych ????????????????????????
« Ostatnia zmiana: 18 Lipiec 2015, 19:53 wysłana przez alcapon »
Korepetycje z ewmapy -> ewmapa@o2.pl
http://www.youtube.com/user/ewmapa/videos

Offline kuczmen

  • *
  • Bywalec
  • *
  • Wiadomości: 12
  • Płeć: Mężczyzna
  • System:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Przeglądarka:
  • Firefox 39.0 Firefox 39.0
    • Zobacz profil
z tej mozaiki coś się wyłania:

1. miałem nieaktualną ewmapę i po zapgrejdowaniu tajemnica niektórych opcji się wyjaśniła :-[
   import obiektów przechodzi bardzo ładnie.
2. ważna jest kolejność importowania - najpierw warstwy, potem obiekty - do tej samej bazy, a nie jak do tej pory robiłem do kartoteki warstw  :-[

2a. pewnie to są oczywistości   ;)
3. problem został rozwiązany, wszystkim zaangażowanym dziękuję.  8)



 

Offline katarzyna

  • *
  • Bywalec
  • *
  • Wiadomości: 38
  • Płeć: Kobieta
  • System:
  • Windows XP Windows XP
  • Przeglądarka:
  • Firefox 41.0 Firefox 41.0
    • Zobacz profil
hej mam ten sam problem,z wyświetlaniem opisu etykieta,zrobiłam jak wyżej ale i tak nie wszystko działa.
Ktoś pomoże
EM 11

Offline Nyzczsel

  • *
  • *
  • Wiadomości: 945
  • Płeć: Mężczyzna
  • System:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Przeglądarka:
  • Chrome 43.0.2357.132 Chrome 43.0.2357.132
    • Zobacz profil
hej mam ten sam problem,z wyświetlaniem opisu etykieta,zrobiłam jak wyżej ale i tak nie wszystko działa.
Ktoś pomoże
EM 11

Nie sprawdzałem ale którą wersję EM11 ?
Jak pisał @kuczmen należy przeprowadzić upgrade EM.

Offline alcapon

  • *
  • *
  • Wiadomości: 1979
  • Płeć: Mężczyzna
  • System:
  • Windows 10 Windows 10
  • Przeglądarka:
  • Edge 12.10240 Edge 12.10240
    • Zobacz profil
hej mam ten sam problem,z wyświetlaniem opisu etykieta,zrobiłam jak wyżej ale i tak nie wszystko działa.
Ktoś pomoże
EM 11

Mapa w załączniku CONAJMNIEJ DZIWNA  :crazy2:
Jeśli zaimportujesz plik z obiektami to mapa wyświetla się prawidłowo....ale
 ktoś sobie wymyślił że w katalogu BDOT500 poza obiektami będzie przechowywał jeszcze zwykłe dane w postaci wektorowej  :2funny:
Dlatego dostałeś jeszcze plik warstwyBDOT   :crazy2:

Aby teraz mapa "wyglądała" normalnie:
1.zaimportuj obiekty
2.zaimportuj warstwy ale z zaznaczeniem opcji " nie dodawaj elementów już istniejących"

Korepetycje z ewmapy -> ewmapa@o2.pl
http://www.youtube.com/user/ewmapa/videos

Offline katarzyna

  • *
  • Bywalec
  • *
  • Wiadomości: 38
  • Płeć: Kobieta
  • System:
  • Windows XP Windows XP
  • Przeglądarka:
  • Firefox 41.0 Firefox 41.0
    • Zobacz profil
Dzięki wielkie .
niby tak robię jak wyżej napisano ale już przy imporcie obiektów wyskakuje "Brak warstwy BUBS w pliku: baza.cnf" i za ....nie chce zaczytać tych obiektów.
a EM 11.2-po upgrade