Shoutbox

support:
2021 Jun 05 21:36:07
w jakimś bliżej nie określonym czasie nastąpi mała zmiana na forum, ale to jak znajdę wolny weekend czy coś podobnego
support:
2020 Nov 12 13:57:35
o taki portal na jakiś czas do nas wpadnie

Modyfikacja obiektów powierzchniowych

  • 19 Odpowiedzi
  • 6061 Wyświetleń

0 użytkowników i 1 Gość przegląda ten wątek.

Offline MarBar

  • *
  • Bywalec
  • *
  • Wiadomości: 11
  • Płeć: Mężczyzna
  • System:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Przeglądarka:
  • Opera 25.0.1614.63 Opera 25.0.1614.63
    • Zobacz profil

Modyfikacja obiektów powierzchniowych

  • dnia: 27 Październik 2014, 18:45
Witam!
Od niedawna pracuje na Ewmapie 11 i natrafiłem na problem, którego nie mogę sam rozwiązać. Dlatego proszę o radę. Jak zmodyfikować istniejący już w bazie obiekt powierzchniowy? Dokładnie chodzi mi o to jak wstawić węzeł na linii obiektu powierzchniowego? Sytuacja wynikła stąd, że mój pomiar parkingu dochodzi do istniejącej drogi i punkty na styku  obiektów trzeba zmodyfikować.
Próbowałem to zrobić uaktywniając istniejący obiekt i wybierając narzędzie "wstaw węzeł", ale niestety to nie działa. Może to u mnie tylko nie działa? Może ma ktoś z Was wiedzę jak to zrobić?? Z góry dzięki za podpowiedzi.
Ps. Ewmapę mam zaktualizowaną do wersji 11.15.

Offline Pan Sowa

  • *
  • Stażysta
  • *
  • Wiadomości: 124
    • Ewmapa 13
  • System:
  • Windows Vista/Server 2008 Windows Vista/Server 2008
  • Przeglądarka:
  • Chrome 38.0.2125.104 Chrome 38.0.2125.104
    • Zobacz profil

Odp: Modyfikacja obiektów powierzchniowych

  • dnia: 27 Październik 2014, 19:19
Narzędzie wstaw węzeł jak najbardziej słuszne działa nawet bez uaktywniania obiektu. Pytanie jaka jest dokladnie sytuacja topologiczna obiektów, dwie linie się przecinają i tam powinien byc wezel, jest wezel i linia... różnie sytuacja moze wygladać. W każdym razie opcja wstaw wezel ma dwa tryby bezwarunkowy i warunkowy. Bezwarunkowy wstawia wezel na rpzecięciu linii, wstawia wezel na linii i dociaga ja do wezla jesli jest w zasiegu celownika. I opcja warunkowa czyli wstawienie wezla gdziekolwiek na linii.
Huuu huu

Offline MarBar

  • *
  • Bywalec
  • *
  • Wiadomości: 11
  • Płeć: Mężczyzna
  • System:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Przeglądarka:
  • Opera 25.0.1614.63 Opera 25.0.1614.63
    • Zobacz profil

Odp: Modyfikacja obiektów powierzchniowych

  • dnia: 27 Październik 2014, 20:59
Nie wiem co robię źle, bo narzędzie wstaw węzeł działa u mnie tylko na warstwach i na obiektach które sam stworzyłem.   Niestety nie działa to na obiektach już istniejących, które dostałem z PODGiK.

Offline Pan Sowa

  • *
  • Stażysta
  • *
  • Wiadomości: 124
    • Ewmapa 13
  • System:
  • Windows Vista/Server 2008 Windows Vista/Server 2008
  • Przeglądarka:
  • Chrome 38.0.2125.104 Chrome 38.0.2125.104
    • Zobacz profil

Odp: Modyfikacja obiektów powierzchniowych

  • dnia: 27 Październik 2014, 21:17
A Twoje elementy znajduja sie na tych samych podwarstwach co podgik-owskie? Jako pierwsza nasuwa mi sie  kwestia aktywacji konkretnej podwarstwy (ew. odznaczenia zielonej kropki na pasku operacje na warstwach).
Huuu huu

Offline MarBar

  • *
  • Bywalec
  • *
  • Wiadomości: 11
  • Płeć: Mężczyzna
  • System:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Przeglądarka:
  • Opera 25.0.1614.63 Opera 25.0.1614.63
    • Zobacz profil

Odp: Modyfikacja obiektów powierzchniowych

  • dnia: 28 Październik 2014, 08:38
Niestety nawet po odznaczeniu "zielonej kropki" nie mogę wstawić tego węzła. Moje nowe obiekty tworzą się na tych samych warstwach, co te z PODGiK-u. Dlatego nie wiem jak to jest możliwe. Nie wiem, czy jest jakaś opcja, która mi to blokuje? Kontaktowałem się ze znajomymi, którzy też pracują na Ewmapie i u nich działa.

Offline Nyzczsel

  • *
  • *
  • Wiadomości: 945
  • Płeć: Mężczyzna
  • System:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Przeglądarka:
  • Chrome 38.0.2125.104 Chrome 38.0.2125.104
    • Zobacz profil

Odp: Modyfikacja obiektów powierzchniowych

  • dnia: 28 Październik 2014, 09:00
Zaznacz obiekt - później ikonka edycji obiektu - wstaw węzeł i zapisz obiekt.

Offline MarBar

  • *
  • Bywalec
  • *
  • Wiadomości: 11
  • Płeć: Mężczyzna
  • System:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Przeglądarka:
  • Opera 25.0.1614.63 Opera 25.0.1614.63
    • Zobacz profil

Odp: Modyfikacja obiektów powierzchniowych

  • dnia: 28 Październik 2014, 16:20
Tak też już próbowałem i nie działa. Sprawdzałem to na kilku moich bazach i na żadnej nie działa. Dziwi mnie to, że mogę użyć tej ikony na swoich obiektach, a na istniejących już nie. Może problem tkwi gdzieś w imporcie obiektów. Ale z drugiej strony w inny sposób np. modyfikacją węzła mogę edytować istniejące obiekty.
sYsTEM połączył wiadomości: 28 Październik 2014, 21:07
Odkryłem właśnie dziwną rzecz, a mianowicie węzeł mogę wstawiać na obiektach, które są za obszarem, który był w zasięgu zgłoszonej pracy. Teraz to ja już zupełnie nie wiem dlaczego tak jest. Może ktoś ma jakiś pomysł???
« Ostatnia zmiana: 28 Październik 2014, 21:07 wysłana przez MarBar »

Offline Pan Sowa

  • *
  • Stażysta
  • *
  • Wiadomości: 124
    • Ewmapa 13
  • System:
  • Windows Vista/Server 2008 Windows Vista/Server 2008
  • Przeglądarka:
  • Chrome 38.0.2125.104 Chrome 38.0.2125.104
    • Zobacz profil

Odp: Modyfikacja obiektów powierzchniowych

  • dnia: 28 Październik 2014, 22:26
Bardzo dziwne:) Próbowaleś może jeszcze raz importowac dane do pustej bazy? Nasuwa mi sie jeszcze kwestia uprawnień ale to też raczej nie to bo nawet jeśli ktoś by sobie ustawił uprawnienia do jakiegoś kodu obiektu to problem byłby w ramach kodu a nie obszaru... ciekawa sprawa. Ewentualnie spróbuj dodać węzeł po staremu. Czyli zacznij polecenie wstaw linie z zaznaczoną opcją węzeł do linii dzieli. Na liniach w obiektach działa więc powinno pomóc (obiektu nie trzeba aktywowac zwyczajnie dopiąć się linią).
Huuu huu

Offline Nyzczsel

  • *
  • *
  • Wiadomości: 945
  • Płeć: Mężczyzna
  • System:
  • Windows 8.1/Server 2012 Windows 8.1/Server 2012
  • Przeglądarka:
  • Chrome 38.0.2125.104 Chrome 38.0.2125.104
    • Zobacz profil

Odp: Modyfikacja obiektów powierzchniowych

  • dnia: 28 Październik 2014, 22:44
Tak też już próbowałem i nie działa. Sprawdzałem to na kilku moich bazach i na żadnej nie działa. Dziwi mnie to, że mogę użyć tej ikony na swoich obiektach, a na istniejących już nie. Może problem tkwi gdzieś w imporcie obiektów. Ale z drugiej strony w inny sposób np. modyfikacją węzła mogę edytować istniejące obiekty.
sYsTEM połączył wiadomości: 28 Październik 2014, 21:07
Odkryłem właśnie dziwną rzecz, a mianowicie węzeł mogę wstawiać na obiektach, które są za obszarem, który był w zasięgu zgłoszonej pracy. Teraz to ja już zupełnie nie wiem dlaczego tak jest. Może ktoś ma jakiś pomysł???

Pomysł może by i się znalazł - ale brak takiej przykładowej bazy rozkłada nas na łopatki.
Dziwne dziwne ...

Offline Lupus

  • *
  • *
  • Wiadomości: 1907
  • Płeć: Mężczyzna
  • Dariusz Wilczewski
  • System:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Przeglądarka:
  • Firefox 32.0 Firefox 32.0
    • Zobacz profil
    • limbus3d.pl

Odp: Modyfikacja obiektów powierzchniowych

  • dnia: 29 Październik 2014, 11:59
Bardzo mało ambitnie podszedłeś do zadania.
Na pewno przychodzi Ci coś do głowy więc poświęć tę "dniówkę", na przeanalizowanie wszystkich możliwych przypadków, a zainteresowany sobie wybierze, ten który pasuje do jego sytuacji.
__________
Pozdrawiam
Lupus

Wszystko da się zrobić, tylko czy jest to uzasadnione ekonomicznie?

Offline MarBar

  • *
  • Bywalec
  • *
  • Wiadomości: 11
  • Płeć: Mężczyzna
  • System:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Przeglądarka:
  • Opera 25.0.1614.68 Opera 25.0.1614.68
    • Zobacz profil

Odp: Modyfikacja obiektów powierzchniowych

  • dnia: 30 Październik 2014, 21:11
A może system operacyjny ma jakieś znaczenie? Tzn. mam win7 i  czy powinienem uruchamiać ewmapę jako administrator, czy normalnie? Zauważyłem, że ma to znaczenie np. przy tworzeniu baz. Może tu tkwi jakiś problem.
ps. Co potrzebujecie, żeby zdiagnozować problem?

Offline Pan Sowa

  • *
  • Stażysta
  • *
  • Wiadomości: 124
    • Ewmapa 13
  • System:
  • Windows Vista/Server 2008 Windows Vista/Server 2008
  • Przeglądarka:
  • Chrome 38.0.2125.104 Chrome 38.0.2125.104
    • Zobacz profil

Odp: Modyfikacja obiektów powierzchniowych

  • dnia: 30 Październik 2014, 21:41
Najlepiej gdybyś przesłał bazę na której występuje problem. :) Wykluczałbym kwestię systemu, przy zakładaniu owszem ma to znaczenie ale głównie dlatego, żeby system zarejestrował sobie "obecność" programu.
Huuu huu

Offline MarBar

  • *
  • Bywalec
  • *
  • Wiadomości: 11
  • Płeć: Mężczyzna
  • System:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Przeglądarka:
  • Opera 25.0.1614.68 Opera 25.0.1614.68
    • Zobacz profil

Odp: Modyfikacja obiektów powierzchniowych

  • dnia: 31 Październik 2014, 08:02
Bazę mogę przesłać, ale tu chyba nie chodzi o bazę tylko o sam program, bo opcja z wstawianiem węzła nie działa mi na żadnej bazie. Tak jak pisałem na początku, dopiero od niedawna pracuje na wersji 11 ewmapy i dotychczas nie używałem tej funkcji. Ale teraz na nowo stworzyłem sobie bazy na plikach, które wcześniej dostawałem z PODGiK i na żadnej nie działa mi ta funkcja wstawiania węzła.

Offline Nyzczsel

  • *
  • *
  • Wiadomości: 945
  • Płeć: Mężczyzna
  • System:
  • Windows 8.1/Server 2012 Windows 8.1/Server 2012
  • Przeglądarka:
  • Chrome 38.0.2125.111 Chrome 38.0.2125.111
    • Zobacz profil

Odp: Modyfikacja obiektów powierzchniowych

  • dnia: 31 Październik 2014, 13:43
Prawa użytkownika do danego katalogu z bazą.
Tyle na temat.
Próbowałeś na koncie z uprawnieniami administratora zrobić węzeł ?
Może baza jest na serwerze do którego masz ograniczony dostęp ?
Gdybanie  :idiot2:

Offline MarBar

  • *
  • Bywalec
  • *
  • Wiadomości: 11
  • Płeć: Mężczyzna
  • System:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Przeglądarka:
  • Opera 25.0.1614.71 Opera 25.0.1614.71
    • Zobacz profil

Odp: Modyfikacja obiektów powierzchniowych

  • dnia: 18 Listopad 2014, 19:48
Z poziomu administratora też próbowałem. Z baz nie korzystam przez serwer, także tutaj chyba nie ma problemu. A może wina leży po stronie Firebird-a? Może podczas instalacji popełniłem jakiś błąd?
A może ktoś mógłby sprawdzić te pliki które dostaje ze PODGiK i zobaczyć u siebie czy to działa?