Shoutbox

support:
2021 Jun 05 21:36:07
w jakimś bliżej nie określonym czasie nastąpi mała zmiana na forum, ale to jak znajdę wolny weekend czy coś podobnego
support:
2020 Nov 12 13:57:35
o taki portal na jakiś czas do nas wpadnie

Autor Wątek: Problem z multieksportem do PODGiK  (Przeczytany 620 razy)

Offline Wyszyn03

  • Bywalec
  • *
  • Wiadomości: 48
    • Zobacz profil
Problem z multieksportem do PODGiK
« dnia: 24 Czerwiec 2021, 19:13 »
Cześć.
Problem wygląda następująco. Przy wykonywaniu inwentaryzacji i późniejszym kartowaniu obiektów z BDOT500, GESUT i EGiB wszystko idzie prosto. Obiekty zapisane i potem robię multieksport z tych trzech baz danych do pliku modyfikującego. Jednak PODGiK nie może podegrać obiektów z EGiB. GESUT i BDOT500 wchodzi bez problemów, ale EGiB zazwyczaj nie przechodzi. Przypadek taki ma miejsce, jeżeli na mapie ten budynek już się znajdował, ale jako projektowany, czy też w budowie. W PODGiK powiedzieli mi, że mam ten budynek po prostu usunąć i skartować już wybudowany i nadać mu taki sam identyfikator jaki miał tamten. A potem telefony z ośrodka, że budynek znowu nie przechodzi.
Macie może jakieś pomysły o co może chodzić? Może chodzi o to, że w bazie PODGiK istnieje już budynek (projektowany albo w budowie) o takim identyfikatorze, jaki ja nadałem budynkowi już wybudowanemu?

Pozdrawiam, Radek.

Offline alcapon

  • Moderator Globalny
  • Legenda
  • *
  • Wiadomości: 1994
    • Zobacz profil
Odp: Problem z multieksportem do PODGiK
« Odpowiedź #1 dnia: 24 Czerwiec 2021, 23:01 »
Istniejący budynek projektowany/w budowie kasujesz i kartujesz budynek wybudowany z takim samym id.
Tak powinno się robić.(robiłem tak tysiące razy)
Jeśli mają jakiś problem to wyeksportuj im do pliku podstawowego tylko skartowany przez ciebie budynek.
Niech ręcznie wykasują u siebie projektowany i zaimportują twój.
Korepetycje z ewmapy -> ewmapa@o2.pl
http://www.youtube.com/user/ewmapa/videos

Offline Wyszyn03

  • Bywalec
  • *
  • Wiadomości: 48
    • Zobacz profil
Odp: Problem z multieksportem do PODGiK
« Odpowiedź #2 dnia: 25 Czerwiec 2021, 07:34 »
Dokładnie tak samo robię i do pewnego czasu nie było żadnych problemów. Później budynki przestały wchodzić. Tak naprawdę nie ma żadnej prawidłowości, bo jak się wczoraj okazało nie wszedł nawet budynek, którego wcześniej na mapie w ogóle nie było (projektowany, czy też w budowie).

Offline staw

  • Stażysta
  • *
  • Wiadomości: 113
    • Ewmapa 13 FB
    • Zobacz profil
Odp: Problem z multieksportem do PODGiK
« Odpowiedź #3 dnia: 25 Czerwiec 2021, 12:52 »
Niech ktoś z podgiku podeśle raport z błędami importu.

Offline Wyszyn03

  • Bywalec
  • *
  • Wiadomości: 48
    • Zobacz profil
Odp: Problem z multieksportem do PODGiK
« Odpowiedź #4 dnia: 28 Czerwiec 2021, 08:53 »
Dzisiaj przesyłam im kolejną inwentaryzację i poproszę o raport.

Offline Wyszyn03

  • Bywalec
  • *
  • Wiadomości: 48
    • Zobacz profil
Odp: Problem z multieksportem do PODGiK
« Odpowiedź #5 dnia: 29 Czerwiec 2021, 17:26 »
Jak na złość teraz budynek wszedł bez problemu. Jeżeli tylko pojawi się błąd przy kolejnych robotach, to od razu go tutaj podeślę.

Offline Wyszyn03

  • Bywalec
  • *
  • Wiadomości: 48
    • Zobacz profil
Odp: Problem z multieksportem do PODGiK
« Odpowiedź #6 dnia: 13 Lipiec 2021, 18:03 »
No i mamy robotę, w której budynek nie chce przejść. Komunikat z raportu:
*********************************
+ Zaimportowano dane (plik: Adresy.eob -> baza: adresy).
+ Zaimportowano dane (plik: BDOT500.eob -> baza: BDOT500).
- Nie zaimportowano danych (plik: Budynki.eob -> baza: budynki).
+ Zaimportowano dane (plik: GESUT.eob -> baza: GESUT).
*********************************

---------------------------------
Raport z importu pliku: Budynki.eob
---------------------------------
Komunikaty wynikające z porównania stanu bazy z importami do modyfikacji i modyfikującym:
Importowany obiekt już istnieje w bazie: EGBB01 1

Dodam, że projektowany budynek usunąłem i wkartowałem nowy o takim samym id jak ten usunięty.

Offline gesiex

  • Słuchacz
  • *
  • Wiadomości: 1
    • Ewmapa 13.
    • Zobacz profil
Odp: Problem z multieksportem do PODGiK
« Odpowiedź #7 dnia: 14 Lipiec 2021, 19:55 »
Podepnę się pod temat.
Zmagam się z problemem dodania podobiektu do istniejącego już w bazie z PODGiK budynku. Podobiektem jest pomierzony taras. Gdy wykonuje multieksport do pliku tekstowego i poźniej podczytuje go na czystej bazie pozyskanej z PODGiK wszystkie zmiany się dokonują oprócz dodania tego tarasu. Dostaje w raporcie taki oto komunikat:
*********************************
+ Zaimportowano dane (plik: Adresy.eob -> baza: Adresy).
+ Zaimportowano dane (plik: BDOT500.eob -> baza: BDOT500).
- Nie zaimportowano danych (plik: Budynki.eob -> baza: Budynki).
+ Zaimportowano dane (plik: GESUT.eob -> baza: GESUT).
*********************************

---------------------------------
Raport z importu pliku: Budynki.eob
---------------------------------
Komunikaty wynikające z porównania stanu bazy z importami do modyfikacji i modyfikującym:
Dane dodatkowe obiektu zostały zmodyfikowane po zrobieniu eksportu do modyfikacji: EGBB01 11-1385/1;1


Nie mam pojęcia co mogę robić źle. (procedura wygląda tak: tworzę taras - zapisuje go jako obiekt - edytuje obiekt budynku - dodaje podobiekt przez wskazanie tarasu - zapisuje obiekt)

Offline Wyszyn03

  • Bywalec
  • *
  • Wiadomości: 48
    • Zobacz profil
Odp: Problem z multieksportem do PODGiK
« Odpowiedź #8 dnia: 16 Lipiec 2021, 08:36 »
Kombinowaliśmy z PODGiK czemu te budynki nie przechodzą. Wpadliśmy na pomysł, żeby oni usunęli ten projektowany ze swojej bazy i dopiero wtedy podegrali ten mój nowy, skartowany. Niestety skutek ten sam. Raport z importu:
*********************************
+ Zaimportowano dane (plik: Adresy.eob -> baza: adresy).
+ Zaimportowano dane (plik: BDOT500.eob -> baza: BDOT500).
- Nie zaimportowano danych (plik: Budynki.eob -> baza: budynki).
+ Zaimportowano dane (plik: GESUT.eob -> baza: GESUT).
*********************************

---------------------------------
Raport z importu pliku: Budynki.eob
---------------------------------
Komunikaty wynikające z porównania stanu bazy z importami do modyfikacji i modyfikującym:
Brak obiektu lub obiekt nieaktualny: EGBB02 3-167/30;

Już nie mamy pomysłu o co może chodzić.

Offline staw

  • Stażysta
  • *
  • Wiadomości: 113
    • Ewmapa 13 FB
    • Zobacz profil
Odp: Problem z multieksportem do PODGiK
« Odpowiedź #9 dnia: 27 Lipiec 2021, 12:30 »
No i mamy robotę, w której budynek nie chce przejść. Komunikat z raportu:
*********************************
+ Zaimportowano dane (plik: Adresy.eob -> baza: adresy).
+ Zaimportowano dane (plik: BDOT500.eob -> baza: BDOT500).
- Nie zaimportowano danych (plik: Budynki.eob -> baza: budynki).
+ Zaimportowano dane (plik: GESUT.eob -> baza: GESUT).
*********************************

---------------------------------
Raport z importu pliku: Budynki.eob
---------------------------------
Komunikaty wynikające z porównania stanu bazy z importami do modyfikacji i modyfikującym:
Importowany obiekt już istnieje w bazie: EGBB01 1

Dodam, że projektowany budynek usunąłem i wkartowałem nowy o takim samym id jak ten usunięty.

Gdzieś już w bazie jest budynek o ID 1.
Najbezpieczniej w roboczej bazie "nazywać obiekty" jakoś losowo.

Offline staw

  • Stażysta
  • *
  • Wiadomości: 113
    • Ewmapa 13 FB
    • Zobacz profil
Odp: Problem z multieksportem do PODGiK
« Odpowiedź #10 dnia: 27 Lipiec 2021, 12:31 »
Podepnę się pod temat.
Zmagam się z problemem dodania podobiektu do istniejącego już w bazie z PODGiK budynku. Podobiektem jest pomierzony taras. Gdy wykonuje multieksport do pliku tekstowego i poźniej podczytuje go na czystej bazie pozyskanej z PODGiK wszystkie zmiany się dokonują oprócz dodania tego tarasu. Dostaje w raporcie taki oto komunikat:
*********************************
+ Zaimportowano dane (plik: Adresy.eob -> baza: Adresy).
+ Zaimportowano dane (plik: BDOT500.eob -> baza: BDOT500).
- Nie zaimportowano danych (plik: Budynki.eob -> baza: Budynki).
+ Zaimportowano dane (plik: GESUT.eob -> baza: GESUT).
*********************************

---------------------------------
Raport z importu pliku: Budynki.eob
---------------------------------
Komunikaty wynikające z porównania stanu bazy z importami do modyfikacji i modyfikującym:
Dane dodatkowe obiektu zostały zmodyfikowane po zrobieniu eksportu do modyfikacji: EGBB01 11-1385/1;1


Nie mam pojęcia co mogę robić źle. (procedura wygląda tak: tworzę taras - zapisuje go jako obiekt - edytuje obiekt budynku - dodaje podobiekt przez wskazanie tarasu - zapisuje obiekt)

Czyżby Ośrodek coś pozmieniał od czasu Twojego eksportu?